1

Тема: Нужны deb-файлы aarddict для n810

Хочу поставить aarddict для википедии, но на его родном сайте все ссылки на репозиторий для Maemo битые, причём давно уже.
Может у кого-то завалялись deb-файлы, хотя бы самого словаря? Зависимости наверное сумею в других репозиториях найти.

2

Re: Нужны deb-файлы aarddict для n810

Здесь то что я собирал
http://n8xx.n8xx.com/aarddict/

Здесь от Ткача
http://github.com/downloads/aarddict/de … -1_all.deb

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

3

Re: Нужны deb-файлы aarddict для n810

Озадачился подобной проблемой....Зашел на оффсайт aarddict,вижу есть википедия за 2011 год,решил обновить,только вот скачанный дамп открывался в словаре с тегами,мудрил со словарем полночи-в итоге случайно удалил сам aarddict  sad.Кинулся искать,и как выше было сказано,все ссылки на репы битые....Вот сижу и не знаю что делать....Нужен именно версии 0.7.6,   0.9.1 ни в какую не хочет устанавливаться. Походил по форуму и понял.что эту версию никому не удалось запустить на 810,во всяком случае решение проблемы установки я не нашел.....
Посоветуйте,как вернуть словарь.Очень нравился,частенько почитывал.....
ЗЫ.Еще один,наверно совсем глупый вопрос-есть бекап,но так думаю,если ссылки битые,то не стоит даже и пытаться восстатовить словать?

4

Re: Нужны deb-файлы aarddict для n810

А что значит "0.9.1 ни в какую не хочет устанавливаться. "?
Я собирал пакеты aarddict для ткача.
У меня стоит 0.9.1

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

5

Re: Нужны deb-файлы aarddict для n810

Если ставить из диспетчера приложенией,то сообщается-"Не удается установить aarddict.Несовместимый пакет приложений".....Куда копать?

6

Re: Нужны deb-файлы aarddict для n810

В wiki несовместимый пакет приложений
http://wiki.n8xx.com/%D0%BD%D0%B5%D1%81 … 0%B8%D0%B9

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

7

Re: Нужны deb-файлы aarddict для n810

Скачал пакет,ввел команду,выдало это-



~ $ root


BusyBox v1.6.1 (2008-09-18 09:43:17 EEST) Built-in shell (ash)
Enter 'help' for a list of built-in commands.

Nokia-N810-43-7:~# dpkg -i aarddict_0.9.1-1_all.deb
dpkg: error processing aarddict_0.9.1-1_all.deb (--install):
cannot access archive: No such file or directory
Errors were encountered while processing:
aarddict_0.9.1-1_all.deb
Nokia-N810-43-7:~#

Что делаю не так?

8

Re: Нужны deb-файлы aarddict для n810

Дело в том что нужно указывать полный путь куда скачали пакет

dpkg -i /Путь к файлу/aarddict_0.9.1-1_all.deb

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

9

Re: Нужны deb-файлы aarddict для n810

Nokia-N810-43-7:~# dpkg -i /media/mmc2/DEB/aarddict_0.9.1-1_all.deb
Selecting previously deselected package aarddict.
(Reading database ... 30470 files and directories currently installed.)
Unpacking aarddict (from .../DEB/aarddict_0.9.1-1_all.deb) ...
dpkg: dependency problems prevent configuration of aarddict:
aarddict depends on python (>= 2.5); however:
  Package python is not installed.
aarddict depends on python-support (>= 0.90.0); however:
  Package python-support is not installed.
aarddict depends on python-pyicu (>= 0.8); however:
  Package python-pyicu is not installed.
aarddict depends on python-pkg-resources; however:
  Package python-pkg-resources is not installed.
aarddict depends on python-qt4 (>= 4.5); however:
  Package python-qt4 is not installed.
dpkg: error processing aarddict (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
aarddict
Nokia-N810-43-7:~#



Теперь вот это выдало.Теперь,как я понимаю,Питона не хватает.Где его взять?

10

Re: Нужны deb-файлы aarddict для n810

Подключить Интернет, войти как root и выполнить:
apt-get -f install

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

11

Re: Нужны deb-файлы aarddict для n810

После этой команды сообщено следующее-


Nokia-N810-43-7:~# apt-get -f install
Чтение списков пакетов... Готово
Построение дерева зависимостей
Reading state information... Готово
Исправление зависимостей... Готово
Пакеты, которые будут УДАЛЕНЫ:
  aarddict
обновлено 0, установлено 0 новых пакетов, для удаления отмечено 1 пакетов, и 17 пакетов не обновлено.
не установлено до конца или удалено 1 пакетов.
Необходимо скачать 0Б архивов.
После распаковки объем занятого дискового пространства уменьшится на 1184kB.
Хотите продолжить [Д/н]? y
(Reading database ... 30692 files and directories currently installed.)
Removing aarddict ...
Nokia-N810-43-7:~#



И еще- какой нужно скачивать и устанавливать пакет,по первой или по второй ссылке?Если по первой,там три пакета их все нужно установить?

12

Re: Нужны deb-файлы aarddict для n810

Нужно добавить репозиторий
http://repository.maemo.org maemo4.1.2/sdk/free
Кое-что есть здесь
http://n8xx.n8xx.com/aarddict/

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

13

Re: Нужны deb-файлы aarddict для n810

Вообщем,после выдачи ошибки от команды  dpkg -i,запустил apt-get -f .Скачались и установилось уйма пакетов,без ошибок установки. Теперь после  dpkg -i выдает следущее



Nokia-N810-43-7:~# dpkg -i /media/mmc2/DEB/aarddict_0.9.1-1_all.deb
(Reading database ... 30925 files and directories currently installed.)
Preparing to replace aarddict 0.9.1-1 (using .../DEB/aarddict_0.9.1-1_all.deb) ...
Unpacking replacement aarddict ...
dpkg: dependency problems prevent configuration of aarddict:
aarddict depends on python-support (>= 0.90.0); however:
  Package python-support is not configured yet.
aarddict depends on pyicu (>= 0.8); however:
  Package pyicu is not installed.
aarddict depends on python-pkg-resources; however:
  Package python-pkg-resources is not configured yet.
dpkg: error processing aarddict (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
aarddict
Nokia-N810-43-7:~#

14

Re: Нужны deb-файлы aarddict для n810

Нужно добавить репозиторий
http://repository.maemo.org maemo4.1.2/sdk/free


svs57,не могли бы уточнить,какую репу нужно добавить с этой страницы?

15

Re: Нужны deb-файлы aarddict для n810

deb http://repository.maemo.org maemo4.1.2/sdk free non-free
deb http://repository.maemo.org maemo4.1.2/tools free non-free

здесь просто кое-какие пакеты
http://n8xx.n8xx.com/aarddict/

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

16

Re: Нужны deb-файлы aarddict для n810

svs57,объясните пожалуйста,как подключить эти репы.Я пытался так-на странице по вашей ссылке выбираю пункт

Repositories for Maemo SDKs

затем

Maemo 4.1 Diablo (browse, install)
deb http://repository.maemo.org/ diablo sdk/free sdk/non-free tools/free tools/non-free
deb-src http://repository.maemo.org/ diablo sdk/free sdk/non-free tools/free tools/non-free

кликаю на "install"
и мне сообщается

Not Found

The requested URL /install/diablo-tools.install was not found on this server.
Apache/2.2.9 (Debian) DAV/2 PHP/5.2.6-1+lenny10 with Suhosin-Patch mod_python/3.3.1 Python/2.5.2 mod_ssl/2.2.9 OpenSSL/0.9.8g mod_perl/2.0.4 Perl/v5.10.0 Server at stage.maemo.org Port 80

Что не так делаю?

17 Отредактировано markel (09-07-2011 11:33:22)

Re: Нужны deb-файлы aarddict для n810

Вроде подключил эту репу через "База данных по репозиториям - Гронмайер ",называется "Maemo SDK".Правильно?

И в целом,какая должна быть моя последовательность действий? Сейчас у меня установлено после команды apt-get -f install PyQt4 Full install( правда после подключения "Maemo SDK",предлагают обновить его,но куча пакетов конфликтует с OS2008 Feature upgrade),затем перекачать ваши deb-ы и установить их. Так?

18

Re: Нужны deb-файлы aarddict для n810

Вот здесь http://n8xx.com/post59567.html#p59567
у вас перечислены пакеты, которых не хватает для установки aarddict.
Их нужно установить либо из репозиториев SDK либо,
скачав  из http://n8xx.n8xx.com/aarddict/.
Тогда и aarddict должен установиться без проблем

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

19

Re: Нужны deb-файлы aarddict для n810

Попробую вернуться к своей проблеме. Установил я все же Aarddict 0.9.3,но запускаться он не хочет,с подобной заковыркой столкнулся не только я.Вот здесь описано решение этой проблеммы http://talk.maemo.org/showthread.php?t=72276 .
Теперь,собственно,сам вопрос-объясните мне немного понятней,что мне нужно сделать.Из крявого гугловского перевода я понял,что их файла python2.5-sip4_4.10.5-maemo0_armel.deb мне нужно извлечь sip.so,перекинуть его в корень карты,сделать его копию и....И вот дальше не совсем пойму,что нужно делать....Получается,что я ничего не меняю,старый фал,меняю на его копию.. И в чем смысл.....
И,если несложно,выложите этот sip.so,мне не на чем извлечь его...

20

Re: Нужны deb-файлы aarddict для n810

Выложил свой
http://n8xx.n8xx.com/aarddict/sip.so
С ним у меня работает aarddict 0.9.3
А какая у вас версия ВиКиПедии

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

21

Re: Нужны deb-файлы aarddict для n810

sys57,спасибо за файлик,все получилось!
Если вы имеете ввиду версию дампа Википедии,то я пользуюсь ruwiki-20110427,сам Aarddict 0.9.3......

22

Re: Нужны deb-файлы aarddict для n810

Ага.
У меня тоже ruwiki-20110427.

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)