Тема: Перестало проигрываться потоковое видео из интернета

После повторной перепрошивки таблетки N810 на OS2008 v.5.2008.43-7 (та же версия до этого и была установлена, перепрошил из-за глюка в теме) перестало проигрываться видео из интернета (youtube, например) во всех плеерах. В Canole при установке соответствующего плагина нормально отображается список воспроизведения с иконками, но выбранный клип не проигрывается (черный экран, ползунок в начале, никаких сообщений). В MediaBox тоже самое, но выскакивает сообщение "connection time out". Пробовал и другие плееры. С интернет-радио проблем нет. Локальное видео проигрывается нормально. Доступ в инет через Wi-fi, скорость нормальная. В настройках соединения ничего не менял. Может после переустаногвки я что-то недоустановил? Может кто сталкивался? Помогите, пожалуйста.

2

Re: Перестало проигрываться потоковое видео из интернета

а браузер тянет?
имхо не установлен какой-нибудь mplayer...

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3

3

Re: Перестало проигрываться потоковое видео из интернета

Через браузер (и мозила, и опера) все нормально воспроизводит, хотя с полноэкранным режимом проблемы+есть притормаживание. Но хочется смотреть через Canol-у, например, - в дороге удобно... Пробовал устанавливать разные плееры, думал может какая-нибудь библиотечка, подтянется, которая была до перепрошивки.. Но не помогло.

4

Re: Перестало проигрываться потоковое видео из интернета

Михаил, прошу прощения.... оперу? Мозила, быть может, ещё с грехом попалам слайдшоу и покажет, но опера флэш вообще не держит. Даже html5.
Вот Микроб и флэш и html5 ест, хоть и со своими приколами smile

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3

5

Re: Перестало проигрываться потоковое видео из интернета

Kroll, дело не в том, что что-то показывает с грехом пополам. Дело в том, что я нормально раньше смотрел через то, что мне было удобно (не через браузер). А после перепрошивки - нет.

6

Re: Перестало проигрываться потоковое видео из интернета

А Canola разве не через mplayer воспроизводит?
Не хочется ставить себе canola  для проверки этого.
Попробуйте установить mplayer

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

7

Re: Перестало проигрываться потоковое видео из интернета

Проблема аналогичная...
Стоит mytube 0.1.5 + mplayer 0.29 - до перепрошивки месяц назад работало, а сейчас - не хочет ни загружать, ни проигрывать само видео...

сплошной Symbian всех версий и мастей -> Toshiba Portege G900+Dell Axim x50v -> Nokia N800+Sony Clie PEG-TG50/U+SE P990i - > Nokia N810+Nokia N85 -> 2xNokia N810+Nokia X2+SE P990i

8

Re: Перестало проигрываться потоковое видео из интернета

1. Покажите вывод команды

dpkg -l mplayer

2. Попробуйте в консоли

mplayer <VIDEO URL>

Вместо <VIDEO URL> нужно подставить реальный видео URL

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

9

Re: Перестало проигрываться потоковое видео из интернета

Вот листинг mplayer <VIDEO URL>:
-----------------------------------------------------------------------------------------------
/home/user # mplayer http://www.youtube.com/watch?v=cN4hSkPRo7E
MPlayer 1.0rc1-maemo.29.n8x0 (C) 2000-2006 MPlayer Team
CPU: ARM
Internet Tablet OS version: RX-34+RX-44+RX-48_DIABLO_5.2008.43-7_PR_MR0
[MENU] Can't open menu config file: /home/user/.mplayer/menu.conf
Menu inited: /etc/mplayer/menu.conf
Playing http://www.youtube.com/watch?v=cN4hSkPRo7E.Resolving www.youtube.com for AF_INET...
Connecting to server www.youtube.com[74.125.39.136]: 80...
Cache size set to 300 KBytes
Cache fill: 10.67% (32768 bytes)
Exiting... (End of file)
/home/user #
----------------------------------------------------------------------------------------------
И все..
Файла /home/user/.mplayer/menu.conf у меня несущетвует.

10

Re: Перестало проигрываться потоковое видео из интернета

Это URL не видео, а html странички.
Вот так нужно:
mplayer http://media-beta.fc-zenit.ru/resources … /63539.flv

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

11

Re: Перестало проигрываться потоковое видео из интернета

Да, и еще:
--------------------------------------------------------------------------------------------------
/etc/mplayer # dpkg -l mplayer
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii mplayer 1.0rc1-maemo.2 The Ultimate Movie Player
/etc/mplayer #
--------------------------------------------------------------------------------------------------

12

Re: Перестало проигрываться потоковое видео из интернета

Сейчас попробую

13

Re: Перестало проигрываться потоковое видео из интернета

Жутко длинно:
--------------------------------------------------------------------------------------------------------------------------
/home/user # mplayer http://media-beta.fc-zenit.ru/resources … /63539.flv


MPlayer 1.0rc1-maemo.29.n8x0 (C) 2000-2006 MPlayer Team


CPU: ARM


Internet Tablet OS version: RX-34+RX-44+RX-48_DIABLO_5.2008.43-7_PR_MR0



[MENU] Can't open menu config file: /home/user/.mplayer/menu.conf


Menu inited: /etc/mplayer/menu.conf



Playing http://media-beta.fc-zenit.ru/resources … 63539.flv.


Resolving media-beta.fc-zenit.ru for AF_INET...


Connecting to server media-beta.fc-zenit.ru[81.23.121.34]: 80...


Cache size set to 300 KBytes


Cache fill:  0.00% (0 bytes)


libavformat file format detected.


Resolving media-beta.fc-zenit.ru for AF_INET...


Connecting to server media-beta.fc-zenit.ru[81.23.121.34]: 80...


Resolving media-beta.fc-zenit.ru for AF_INET...


Connecting to server media-beta.fc-zenit.ru[81.23.121.34]: 80...


Resolving media-beta.fc-zenit.ru for AF_INET...


Connecting to server media-beta.fc-zenit.ru[81.23.121.34]: 80...


Resolving media-beta.fc-zenit.ru for AF_INET...


Connecting to server media-beta.fc-zenit.ru[81.23.121.34]: 80...


VIDEO:  [FLV1]  552x330  0bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)


[omapfb] Nokia N800/N810 hardware detected


[omapfb] tearsync is enabled

==========================================================================

Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family


Selected video codec: [ffflv] vfm: ffmpeg (FFmpeg Flash video)

==========================================================================
==========================================================================

Trying to force audio codec driver family dspmp3...


Opening audio decoder: [dspmp3] MP3 audio pass-through for Nokia 770/N800 (fake decoder)


ADecoder preinit failed sad


ADecoder init failed sad


Trying to force audio codec driver family libmad...


Opening audio decoder: [libmad] libmad mpeg audio decoder


AUDIO: 44100 Hz, 2 ch, s16le, 256.0 kbit/18.14% (ratio: 32000->176400)


Selected audio codec: [mad] afm: libmad (libMAD MPEG layer 1-2-3)

==========================================================================

[AO SDL] Samplerate: 44100Hz Channels: Stereo Format s16

le
AO: [sdl] 44100Hz 2ch s16le (2 bytes per sample)


Starting playback...


VDec: vo config request - 552 x 330 (preferred colorspace: Planar YV12)


VDec: using Planar YV12 as output csp (no 0)


Movie-Aspect is undefined - no prescaling applied.


VO: [omapfb] 552x330 => 552x330 Planar YV12  [fs] [zoom][omapfb] ARM JIT scaler (quality=2): 552x330 YV12 => 552x330 YUV420

process 5322: D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/var/lib/dbus/machine-id": No such file or directory
See

the manual page for dbus-uuidgen to correct this issue.
 

D-Bus not built with -rdynamic so unable to print a backtrace




MPlayer interrupted by signal 6 in module: stop_maemo_screensaver


- MPlayer crashed. This shouldn't happen.
 

It can be a bug in the MPlayer code _or_ in your drivers _or_ in your
  gcc version. If you think it's MPlayer's fault, please read
  DOCS/HTML/en/bugreports.html and

follow the instructions there. We can't and
  won't help unless you provide this information when reporting a possible bug.


/home/user #
---------------------------------------------------------------------------------------------------------------------

14

Re: Перестало проигрываться потоковое видео из интернета

svs57
Абсолютно все так же как и у Михаила  sad
Похоже на баг с самим МПлеером. Сейчас попробую 28 или 27 поставить...
ЗЫ. Кстати плаг для МикроБа для проигрывания видео МПлеером так же его не подхватывает...

сплошной Symbian всех версий и мастей -> Toshiba Portege G900+Dell Axim x50v -> Nokia N800+Sony Clie PEG-TG50/U+SE P990i - > Nokia N810+Nokia N85 -> 2xNokia N810+Nokia X2+SE P990i

15

Re: Перестало проигрываться потоковое видео из интернета

А, ну это ютуб опять поменял всё к чертям. У меня @scene тоже не кажет.
http://talk.maemo.org/showthread.php?t= … t=%40scene

При этом говорят что cuteTube пашет. Есть ли он на n810 - пока не проверял.

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3

16

Re: Перестало проигрываться потоковое видео из интернета

имхо mplayer тут не при чем.
Ругается на отсутствие
/var/lib/dbus/machine-id
Попробуйте от рута запустить

dbus-uuidgen --ensure

для создания нового machine-id

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

17

Re: Перестало проигрываться потоковое видео из интернета

svs57
Запустил. Не помогло(

сплошной Symbian всех версий и мастей -> Toshiba Portege G900+Dell Axim x50v -> Nokia N800+Sony Clie PEG-TG50/U+SE P990i - > Nokia N810+Nokia N85 -> 2xNokia N810+Nokia X2+SE P990i

18

Re: Перестало проигрываться потоковое видео из интернета

А файл /var/lib/dbus/machine-id появился?
mplayer так и ругается на его отсутствие?

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

19

Re: Перестало проигрываться потоковое видео из интернета

http://talk.maemo.org/showpost.php?p=91 … tcount=378

Возрадуйся, вот он фикс.


п.с. мплэер тот же что и полгода назад - микроб как тянет ютуб, так и тянет. Хуже чем тиар, конечно, но тем не менее.

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3

20

Re: Перестало проигрываться потоковое видео из интернета

После запуска "dbus-uuidgen --ensure" по рекомендации svs57, mplayer  начал показывать из командной строки .flv. Но проблема с другими плеерами не решилась. Думаю, дело не в mplayer.

21

Re: Перестало проигрываться потоковое видео из интернета

Да не в этом дело, ютуб АПИ сменил. Уже не в первый раз. Просто нужно применить фиксы, MyTube фикс я дал постом выше.

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3

22

Re: Перестало проигрываться потоковое видео из интернета

Прошу прощения за избитый вопрос-как применить этот фикс?какие команды ввести?

23

Re: Перестало проигрываться потоковое видео из интернета

markel пишет:

Прошу прощения за избитый вопрос-как применить этот фикс?какие команды ввести?

Способ сложнее: http://talk.maemo.org/showpost.php?p=91 … tcount=383
Способ легче: http://talk.maemo.org/showpost.php?p=92 … tcount=390

А вообще почитайте ту темку smile

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3

24

Re: Перестало проигрываться потоковое видео из интернета

Из описания более простого способа,как я понял,нужно скопировать файл YouTube-DL-х в в каталог / USR / Bin.
Правильно ли я сделал-запустил терминал,получил права рута,из терминала же запустил МС,нашел скачанный файл-патч,далее "команда"-"копировать".В открывшемся окне меня спрашивают-"Копировать файл *youtube-dl-x* с исходным шаблоном в /usr/bin"? Жму ввод.В новом окне сообщают,что целевой файл */usr/bin/youtube-dl-x* уже существует.Дата модификации источника......Дата модификации приемника.....(помню,что один файл 2008 г,другой 2011).Перезаписать?
Снова жму "Ввод". Вроде прошел процесс перезаписи успешно.
Запускаю myTube,но как не происходило воспроизведение клипов,так и не происходит....
Может я что не так сделал? Или нужно что то еще сделать?

25

Re: Перестало проигрываться потоковое видео из интернета

Ну вам нужно было разархивировать пакет. Если сделали, то скорее всего забыли сделать это:
консоль, становитесь рутом, cd /usr/bin (это мы перешли в директорию бин) и пишем
chmod +x ./youtube-dl-x (или как там его)

Теперь попробуйте поиграть видео.

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3