51 Отредактировано mel (27-12-2011 06:31:03)

Re: Графический редактор

вообщем так, недостающий PyGTK я нашёл http://ftp.gnome.org/pub/GNOME/sources/pygtk/

но так как pygtk-2.24.0.tar.bz2 и pygtk-2.24.0.tar.gz не rpm или deb то не знаю как поставить, но это уже не к теме. Как поставлю PyGTK , запущу MyPaint и отпишусь.

--------
Поставить PyGTK не вышло, так как встала проблема с правами доступа при установки ./configure которая не решалась не через chmod не через Midnight Commander. Пошёл на джаббер конференцию где мне сказали:

4:59:35] <deamk> Mel: как бы он более новую версию требует.
[05:00:03] <Mel> вот-с на гном орг уже 2.24.0 есть
[05:00:09] <deamk> Но - ты её не сможешь поставить, потому что libc старый. Либо ставь MyPaint старее, либо - EasyDebian
[05:00:14] <Mel> но тогда возвращаемся к первому вопросу))
[05:00:52] <Mel> а почему нельзя просто установить 2.24.0 ?
[05:01:18] <deamk> Mel: зависимости не позволят.

будем кумекать...отпишусь

----
РЕШЕНИЕ НАЙДЕНО:

http://forums.internettablettalk.com/sh … stcount=86

Вообщем заходим в x-terminal
root
потом
cd /opt/mypaint/share/mypaint/gui/
sed -i 's/assert gtk.ver/#assert gtk.ver/g' main.py

Таким образом убирается 13 строчка в файле main.py которая отвечает за проверку версии PyGTK.

Выходим и запускаем MyPaint из основного меню.