1

Тема: Зависимости...

Пробую поставить несколько нужных мне приложений:
Mediabox и FM-radio, на что получаю ответ о неудовлетворенных зависимостях.
Через apt-get install нужные либы не качаются, мотивируя тем что конфликт. Для решения конфликта предлагает запустить с ключом -f, и при этом радостно заявляет что грохнет 25 пакетов которые я ставил ранее - среди них Canola2 и еще куча ПО.
Скачиваю либы вручную, ставлю через dpkg -i, опять конфликты.
Как-нибудь можно решить проблему с зависимостями раз и навсегда?
Который вечер ложусь спать в час ночи с затекшими плечами от тыкания стилусом.

2

Re: Зависимости...

Ну во-первых незачем тыкать стилусом, т.к. есть ssh.
А что вы хотели? Чтобы пакеты ставились, а потом не работали?
На то и зависимости. Одному нужно одно, а другому другое.
Раз и навсегда никогда не разрешить.

Был бы у Чехова автомобиль, поворотник бы Чехов включал.
N810 (DIABLO_5.2008.43-7)

3

Re: Зависимости...

Sith_Lord, у Вас же по-моему N810? Зачем Вам FM-radio? Приемника-то в 810 физически нет.

Если все перепробовал и ничего не помогает, прочти наконец инструкцию!
N900, N9

4

Re: Зависимости...

aboris пишет:

Sith_Lord, у Вас же по-моему N810? Зачем Вам FM-radio? Приемника-то в 810 физически нет.

Ошибаетесь, у меня N800 smile

5

Re: Зависимости...

Здравствуйте, все!

У меня тоже постоянно ругань идет во время обновления.
В линуксе я профан, поэтому хотелось бы спросить у более продвинутой общественности. Неужели нет способа держать несколько версий одного и того же пакета? И чтобы каждая прога использовала нужный ей.
chroot не об этом ли?

PS Учитывая, что ОС перенесена на карту, занимаемое место не очень критично.

6

Re: Зависимости...

В линуксе некоторые либы и даже тулзы живут одновременно в нескольких версиях. Но для этого требуется соответствующим образом создавать такие пакеты, а зависящие от них пакеты должны быть привязаны к конретной версии пакета.
Т.е. способы есть, но надо глубоко погружать ручки. Да и неудобства всплывут.

Был Nokia N800 + A-Data SDHC6 4Gb + Kingston SDHC6 8Gb + Nokia 5610 + USBHDD + Card Readers + Palm TT3 + Linksys WRT54G / OpenWRT + Megafon EDGE + BT GPS Holux M1000.

7

Re: Зависимости...

Я, собственно не особо-то и надеялся.
Хотя наличие такого менеджера пакетов напрашивается.
В интерфейсе это могло бы выглядеть так: при конфликте пакетов устанавливать "сбоку".
Ну да ладно. И на том спасибо.

8

Re: Зависимости...

ive, дефолтный менеджер сам по себе тошнотворный smile Xlab сказал что тот же синаптик не получается портировать... а жаль sad

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3

9

Re: Зависимости...

КПК с линуксом на борту - настоящая портативная секс-машинка, которая всегда с тобой lol

10

Re: Зависимости...

Эхо какое-то от Kroll

Был Nokia N800 + A-Data SDHC6 4Gb + Kingston SDHC6 8Gb + Nokia 5610 + USBHDD + Card Readers + Palm TT3 + Linksys WRT54G / OpenWRT + Megafon EDGE + BT GPS Holux M1000.

11

Re: Зависимости...

Удалил эху smile А чем синаптик был бы лучше ? пользуйтесь apt-get - от него не тошнит.

GNU/Linux Debian / Nokia N900 / N9

12

Re: Зависимости...

Sith_Lord пишет:

КПК с линуксом на борту - настоящая портативная секс-машинка, которая всегда с тобой lol

Кто то из разработчиков maemo сказал что N800 - best porno device, потому что управлять им можно одной левой рукой smile

GNU/Linux Debian / Nokia N900 / N9

13

Re: Зависимости...

Dali пишет:

Эхо какое-то от Kroll

Два раза сообщение? О_о
А синаптик позволяет отметить кучу софта галками и одной кнопкой применить. А в существующем менеджере полный секс, после каждой установки он долго думает, обновляет чего-то там и т.п.

Nokia n810 Maemo OS2008 5.2010.33-1
Nokia N9 1.3